Personal Dashboard - Unable to release quaratine emails

Incident Report for edgewave.com

Resolved

This incident has been resolved.
Posted Jan 27, 2020 - 14:58 PST

Investigating

We are currently investigating an issue where users are unable to release or download quarantined email from their personal dashboards.
Posted Jan 27, 2020 - 11:04 PST
This incident affected: ePrism (ePrism Hosted Service).