Mail Delivery Delays

Incident Report for edgewave.com

Resolved

This incident has been resolved.
Posted Apr 17, 2020 - 14:49 PDT

Monitoring

Issue has been mitigated and we are monitoring.
Posted Apr 17, 2020 - 09:55 PDT

Update

We are continuing to investigate this issue.
Posted Apr 17, 2020 - 09:45 PDT

Investigating

We are currently investigating an issue with email delays.
Posted Apr 17, 2020 - 09:44 PDT